Come far funzionare il mod rewrite con Ultimate Tag Warrior

Se usate Ultimate Tag Warrior per gestire i tag sul vostro blog WordPress potreste incontrare problemi qualora abilitiate il mod rewrite per i tag (dal pannello di WordPress, Options -> Tags).

Per motivi che non mi metto a spiegare perché non sono neanche sicuro di averli capiti appieno io, potreste ricevere un error 404 quando visitate la pagina di un tag in locale (ad esempio, www.vostroblog.com/tag/bug/).

All’inizio cercavo la soluzione all’interno del file .htaccess, ma in realtà mi sono accorto che è sufficiente ricostruire la struttura dei permalink (Options -> Permalinks) dopo aver abilitato il mod rewrite per i tag.

Qualora continuiate a ricevere error 404, provate, prima delle due modifiche via pannello di cui sopra, ad inserire nel file .htaccess queste due righe (subito dopo la riga “RewriteBase /”):

RewriteCond %{REQUEST_URI} ^(/tag)
RewriteRule ^tag/(.*)/$ /index.php?tag=$1 [L]

Ma nonostante questa sia una soluzione che ho trovato in giro per Internet, ho verificato (anche su questo stesso blog) che non è sempre un passaggio necessario.

Perdo i tag

Piccola richiesta d’aiuto: su questo blog wordpress uso Ultimate Tag Warrior per gestire i tag. Solo che ultimamente mi sono accorto che si perde i tag e mantiene solo quelli delle categorie.
Idee o suggerimenti per capire che succede?

Di chi era, il bug?

Come scritto, c’era un bel bug su WordPress 2.1 che si manifestava nella congiuntura astrale WordPress 2.1 + Debian Stable con php 4.3.10-18 + widgets.

Nel gioco dello scaricabarile (pensavate fosse una specialità tutta italiana?), qualcuno osò dire che il bug era di Debian. Intendiamoci, mi piace la gente con un minimo di temerarietà. Però se poi aggiorno wordpress alla 2.1.1 e non vedo più segmentation fault, si capisce di chi era il bug.